
Zilog TCP/IP Software Suite
Quick Start Guide QS004914-1211
Introduction
This quick start guide helps you to get started with the Zilog TCP/IP Software Suite for 
Zilog’s eZ80Acclaim!® family, which includes the eZ80F91, eZ80F92 and eZ80F93 
microcontrollers and the eZ80L92 microprocessor.

ZTP Overview
The Zilog TCP/IP Software Suite (ZTP) is an integrated, preemptive, multitasking operat-
ing system and TCP/IP protocol stack that is optimized for embedded systems. Powered 
by the Zilog Real-Time Kernel (RZK), ZTP offers full-feature operating system and net-
work services that occupy a minimum of program memory. Applications can be integrated 
with ZTP through its easy-to-use and well-documented Application Programming Inter-
faces (APIs).

ZTP software can be visualized as two planes:

• The first plane, referred to as the OS plane, represents the Zilog Real-Time Operating 
System, RZK

• The second plane, referred to as the stack plane, represents the embedded TCP/IP pro-
tocol stack

Modules in the stack plane require the services of the OS plane to ensure that they coexist 
with other applications that compete for the processor. The OS plane includes the follow-
ing features:

• Scheduler

• Memory manager

• Interprocess communications services

Table 1 lists the names of each of the layers in the ZTP protocol stack by client, server or 
peer type.
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System Requirements
This section describes the hardware and host system requirements for installing and using ZTP.

Target Hardware Requirements
ZTP is intended to be used with the following members of the eZ80Acclaim! family of 
microcontrollers: eZ80F91, eZ80F92, eZ80F93 and eZ80L92. Sample projects included 
with ZTP target eZ80 development kits that contain one of these microcontrollers. Please 
refer to the documentation included with your particular eZ80 development kit to learn 
how to set up your eZ80 development kit hardware.

Table 1. ZTP Protocol Layers 

Protocol Full Name Client, Server or Peer

ARP Address Resolution Protocol Peer

DHCP Dynamic Host Configuration Protocol Client

DNS Domain Name Server Client

FTP File Transfer Protocol Client and Server

HTTP Hypertext Transfer Protocol Server

ICMP Internet Control Message Protocol Peer

IGMP Internet Group Management Protocol Peer

IP Internet Protocol Peer

PPP Point-to-Point Protocol Peer

PPPoE Point-to-Point Protocol over Ethernet Client

RARP Reverse Address Resolution Protocol Peer

SMTP Simple Mail Transfer Protocol Client

SNMP Simple Network Management Protocol Server

SNTP Simple Network Time Protocol Client

SSL* Secure Socket Layer Protocol Server 

TCP Transmission Control Protocol Peer 

Telnet Telnet Client and Server

TFTP Trivial File Transfer Protocol Client

TimeP Time Protocol Client

UDP User Datagram Protocol Peer
Note: *The SSL protocol is available only with the SSL package.
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Recommended Host System Configuration
Please refer to the Zilog Developer Studio II - eZ80Acclaim! User Manual (UM0144) to 
determine your minimum host system configuration. When connecting the debug hard-
ware to the host PC, please refer to the Ethernet Smart Cable User Manual (UM0207) or to 
the USB Smart Cable User Manual (UM0181).

Installing and Uninstalling ZTP
The ZTP TCP/IP Software Suite is integrated with ZDS II and is an integral part of the 
ZDS II installation. Installing or uninstalling ZDS II automatically installs or uninstalls 
ZTP.

Installing ZTP
Observe the following procedure to install ZTP:

1. Copy the ZDSIIeZ80_Acclaim_<version>.exe file to an appropriate directory on 
the host PC.

2. Launch ZDSIIeZ80_Acclaim_<version>.exe to install ZTP. By default, the 
installation path is C:\Program Files\Zilog.

Uninstalling ZTP
To uninstall ZTP, launch the InstallShield Wizard. When the InstallShield Wizard finds 
an already-installed version of ZDS II, it allows you to modify, repair or remove the previ-
ous installation. Alternatively, navigate via the Windows Start menu to Settings → Con-
trol Panel → Add and Remove Programs to select the installed version of ZDS II and 
uninstall it from the PC.

The ZTP Directory Structure
After installing ZDS II on your PC, the ZTP directory structure is created in the installed 
directory. By default, ZTP is installed in the following path:

C:\Program Files\Zilog\ZDSII_eZ80Acclaim!_A.B.C\ZTP\ZTPX.Y.Z_Lib

In this path, A.B.C represents the ZDS II version number, and X.Y.Z represents the ver-
sion number of the ZTP release. Figure 1 displays the hierarchy of the ZTP directory 
structure.
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The ..\ZTP\Docs directory is a common directory that includes all ZTP-related docu-
ments. Table 2 lists the files contained within the ..\ZTP\Docs directory.

Figure 1. Directory Structure of the ZTP_X.Y.Z_Lib Release
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Hardware Setup
Figures 2 and 3 display the typical hardware setup for the ZTP sockets demo application 
that is used to illustrate socket programming for the network data transfer. The hardware 
setup in Figure 2 uses Ethernet Smart Cable and Figure 3 uses Serial Smart Cable/USB 
Smart Cable for debugging.

Table 2. ZTP-Related Documents 

Directory Documents Title

..\ZTP\Docs RM0040 Zilog TCP/IP Software Suite Reference 
Manual

RM0041 Zilog TCP/IP Software Suite 
Programmer’s Guide

QS0049 Zilog TCP/IP Software Suite Quick Start 
Guide

PB0154 Zilog TCP/IP Software Suite Product 
Brief

RZK_ZTP_ReleaseNotes.txt Zilog TCP/IP Software Suite Release 
Notes for the ZDS II release

Figure 2. Hardware Setup for ZTP Demo Applications Using ZPAK II

Ethernet Smart Cable

Development PC
eZ80®

Development
Platform

eZ80®

Dev.
Module

ZDS II

5 VDC 9 VDC

RJ-45RJ-45

RS-232

Ethernet
Hub
QS004914-1211 Page 5 of 12



Zilog TCP/IP Software Suite
Quick Start Guide
Observe the following procedure to set up the hardware:

1. Set the jumper pin connections on the eZ80 Development Platform to their default 
settings.

2. Connect the power supply (9 V) cables to the eZ80 Development Platform.

3. If you are using the Ethernet Smart Cable, continue to Step 4. If you are using the 
Serial Smart Cable, skip ahead to Step 7. If you are using the USB Smart Cable, skip 
to Step 8.

4. Connect the Ethernet Smart Cable’s 6-pin header to the ZDI J4 port on the eZ80 
Development Platform.

5. Connect one end of the RJ-45 cable to the Ethernet port on the Ethernet Smart Cable 
unit, and connect the other end to the LAN. This connection is required if you plan to 
debug your project with ZDS II.

6. Connect the power supply (5 V) to the Ethernet Smart Cable unit, then skip to Step 9.

7. Connect the ZDI target interface module of the Serial Smart Cable to the ZDI J4 port 
on the eZ80 Development Platform, and connect the other end to the serial port on the 
Development PC.

8. Connect the ZDI target interface module of the USB Smart Cable to the ZDI J4 port 
on the eZ80 Development Platform, and connect the other end to the USB port on the 
Development PC.

9. Connect one end of the RJ-45 cable to the Ethernet port on the eZ80xxx module, and 
connect the other end to the LAN.

Figure 3. Hardware Setup for ZTP Demo Applications Using 
a Serial Smart Cable or USB Smart Cable
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10. Connect the RS-232 cable to the eZ80 Development Platform and to the COM1 port 
of the Development PC.

Configuring the HyperTerminal Application
Before starting the demo application, observe the following procedure to configure the 
HyperTerminal program.

1. In Windows, launch the HyperTerminal application by navigating via the Windows 
Start menu to Programs → Accessories → Communications → HyperTerminal. 
The Connection Description dialog box appears.

2. Enter the name for a new connection in the Connection Description dialog and click 
OK. The Connect To dialog box appears.

3. In the Connect using: text field, select the COM port to which the serial cable is con-
nected, then click OK. The Port Settings dialog box appears for the selected port.

4. In the Port Settings dialog box, enter the following values in their respective text 
fields:

5. Click OK. The connection to the eZ80 Development Platform is established via the 
serial port.

6. Click RESET on the eZ80 Development Platform.

Executing the ZTP Demo Application
The following sections describe how to execute the ZTP demo application.

Running the RAM-Based ZTP Demo Project Using ZDS II
Observe the following procedure to execute the ZTP demo project in the ZDS II develop-
ment environment.

Bits per second 57600 bps

Data bits 8

Parity None

Stop bits 2

Flow control None 
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An SMTP server is required to run the ZTP demo project.

1. Set up the hardware as shown in Figure 2 on page 5.

2. Launch ZDS II by clicking the Windows Start menu and selecting All Programs. 
Scroll through the list of programs and select the Zilog ZDS II – eZ80Acclaim! X.Y.Z 
folder option, then click ZDS II – eZ80Acclaim!_A.B.C.

3. From the File menu in ZDS II, select Open Project to open the sample ZTP demo 
project. This project is located in the following path:

<ZDS Installed Dir>\ZTP\ZTPX.Y.Z_Lib\ZTP\SamplePrograms\
ZTPDemo\ZTPDemo_xxx.zdsproj>

In the above path, xxx represents the eZ80F91, eZ80F92, eZ80F93 or eZ80L92 target 
device.

4. From the Project menu in ZDS II, select Settings. The Project Settings dialog box 
appears.

5. In the Project Settings dialog box, select the Debugger tab. In the Debugger tab, the 
appropriate target-setting file is checked.

6. Click the Setup button in the Debugger tab under Debug Tool. The Setup Ethernet 
Smart Cable Communication dialog box appears. Select Ethernet Smart Cable. 
(For development kits that do not include an Ethernet Smart Cable, select the Serial 
Driver target setting instead of the Ethernet Driver target setting.)

7. In the IP Address field of the Setup Ethernet Smart Cable window, the IP address is 
selected automatically.

8. Click OK in the Setup Ethernet Smart Cable Communication dialog box to return 
to the Project Settings dialog box.

9. Click OK to close the Project Settings dialog box.

10. As the network configurations apply to the network, change the default network set-
tings in the iftbl structure table of the ZTPConfig.c configuration file, which is 
located in the ..\ZTP\Conf folder of the library package. In the iftbl for the Ether-
net interface, specify the default IP address, the default gateway and the default subnet 
mask. For details about how to change these default network settings, refer to the 
Zilog TCP/IP Software Suite Programmer’s Guide (RM0041).

Note:
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11. Select Build → Set Active Configuration to open the Select Configuration dialog 
box. In this dialog, select the RAM configuration.

12. Select Build → Rebuild All to rebuild the application and generate a 
ZTPDemo_xxx_Ram.lod file.

13. Select Debug → Download Code to download the ZTPDemo_xxx_Ram.lod file, 
located in the project path, to the eZ80 Development Platform.

14. To run the demo application, select Debug → Go. To use the ZTP demo application, 
see the Using ZTP section on page 10.

Running an HTTP Server on the eZ80F910200KITG Kit
Observe the following procedure to run an HTTP server using the eZ80F910200KITG 
Development Kit.

1. Set up the hardware as displayed in Figure 2 on page 5.

2. Launch ZDS II by clicking the Windows Start menu and selecting All Programs. 
Scroll through the list of programs and select the Zilog ZDS II – eZ80Acclaim! X.Y.Z 
folder option, then click ZDS II – eZ80Acclaim!_A.B.C.

3. From the File menu in ZDS II, select Open Project to open the sample ZTP demo 
project. This project is located in the following path:

<ZDS Installed Dir>\ZTP\ZTPX.Y.Z_Lib\ZTP\SamplePrograms\
ZTPDemo\ZTPDemo_F91_Mini.zdsproj>

4. FollowSteps 4 through 10 in the Running the RAM-Based ZTP Demo Project Using 
ZDS II section on page 7.

5. Select Build → Set Active Configuration to open the Select Configuration dialog 
box. In this dialog, select the Flash configuration.

6. Select Build → Rebuild All to rebuild the application and generate a 
ZTPDemo_F91_Mini.hex file.

7. Select Debug → Download Code to download the ZTPDemo_F91_Mini.hex file, 
located in the project path, to the eZ80F91 Mini E-Net Development Platform.

8. To run the demo application, select Debug → Go. 

9. During initialization, the ZTPDemo project will display its IP address in the PC’s ter-
minal program. Record this IP address (write it down) so that it can be used in subse-
quent steps.
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10. On the PC, launch a web browser (such as Internet Explorer).

11. In the browser’s URL text box (a.k.a. URL bar), enter a.b.c.d. This a.b.c.d octet 
nomenclature represents the IP address that you recorded in Step 9.

Using ZTP
Observe the following procedure to use ZTP’s set of features.

1. When you execute the ZTP demo application on any of the eZ80 development 
platforms, a login prompt is displayed in the HyperTerminal application. 

2. The ZTP shell login and password are set in the ZTPConfig.c file, which is located 
in the ..\ZTP\Conf folder. Log in with these credentials to the ZTP shell. 

The default username and password are anonymous and anonymous, 
respectively.

3. To view a list of shell commands, enter the question mark (?) character or the help 
command in the ZTP shell.

The following operations are performed in the ZTP demo:

1. Print network interface information for all of the available interfaces using the 
ifstat shell command.

Sample Usage
[ZTP EXTF:/]>ifstat
------------------------------------------------------------
IFace IP address Def Gtway State Type H/W Address
0 172.16.6.53 172.16.6.1 UP Ethernet 0:90:23:0:9:9
1 192.168.2.1 192.168.2.2 DOWN PPP —
------------------------------------------------------------

The interface information above is also displayed while the system is booting up.

2. Browse the ZTP web pages by specifying the IP address of the eZ80 CPU as a URL in 
a browser running on a workstation. Ping can also be initiated from the ZTP shell 
prompt to any other workstation.

3. Ping the eZ80 CPU by specifying the IP address of the workstation.

4. Add a user to the eZ80 database using the addusr command. You can log in from an 
FTP client, Telnet client, or the HyperTerminal shell, provided that the system admin-

Note:
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istrator has already set your username and password. The default login and password 
are anonymous and anonymous, respectively. 

Sample Usage
[ZTP EXTF:/]>addusr john john123

5. Use the mail shell command to interactively compose an email message that is sent to 
an SMTP server for delivery to a specified recipient. 

Sample Usage
[ZTP EXTF:/]>mail
Press <ESC> then <Enter> to exit early
Enter the name or IP of the SMTP server: zilog.com
Enter the port number to connect to (normally 25): 25
Enter the email Subject: ez80
Enter the recipient's email address:sclaus@northpole.com
Enter the sender's email address: ez80@zilog.com
Enter the body of the email (ESC/Enter to complete):test
mail
^[
Please wait while the message is processed.
Mail message was successfully sent.

To learn more about these shell commands, refer to the ZTP Shell Command Reference 
section of the Zilog TCP/IP Software Suite Programmer’s Guide (RM0041).

Creating a New ZTP Project
The simplest way to create a new ZTP project is to copy one of the existing sample proj-
ects into a new folder and modify it as per your requirements. For information about how 
to add and remove files from a project, as well as a description of the advanced features of 
the tool, refer to the Zilog Developer Studio II – eZ80Acclaim! User Manual (UM0144). 
For details about creating new projects and the required settings for RAM projects, refer to 
the Zilog TCP/IP Software Suite Programmer’s Guide (RM0041). 

Related Documentation
The following documents apply to the eZ80Acclaim! family of microcontrollers, which 
includes the eZ80F91, eZ80F92 and eZ80F93 MCU and the eZ80L92 MPU.

• Zilog Developer Studio II – eZ80Acclaim! User Manual (UM0144)
• eZ80 CPU User Manual (UM0077)
• eZ80Acclaim! External Flash Loader Product User Guide (PUG0016)
• ZPAK II Debug Interface Tool Product User Guide (PUG0015)
• eZ80Acclaim! Development Kits Quick Start Guide (QS0020)
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Customer Support
To share comments, get your technical questions answered, or report issues you may be 
experiencing with our products, please visit Zilog’s Technical Support page at 
http://support.zilog.com.

To learn more about this product, find additional documentation, or to discover other fac-
ets about Zilog product offerings, please visit the Zilog Knowledge Base at http://
zilog.com/kb or consider participating in the Zilog Forum at http://zilog.com/forum.

This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, please visit the Zilog website at http://www.zilog.com.

DO NOT USE THIS PRODUCT IN LIFE SUPPORT SYSTEMS.

LIFE SUPPORT POLICY

ZILOG’S PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL 
COMPONENTS IN LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE 
EXPRESS PRIOR WRITTEN APPROVAL OF THE PRESIDENT AND GENERAL 
COUNSEL OF ZILOG CORPORATION. 

As used herein
Life support devices or systems are devices which (a) are intended for surgical implant into the body, or (b) 
support or sustain life and whose failure to perform when properly used in accordance with instructions for use 
provided in the labeling can be reasonably expected to result in a significant injury to the user. A critical 
component is any component in a life support device or system whose failure to perform can be reasonably 
expected to cause the failure of the life support device or system or to affect its safety or effectiveness.

Document Disclaimer
©2011 Zilog, Inc. All rights reserved. Information in this publication concerning the devices, applications, or 
technology described is intended to suggest possible uses and may be superseded. ZILOG, INC. DOES NOT 
ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF ACCURACY OF THE 
INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS DOCUMENT. ZILOG ALSO 
DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROPERTY INFRINGEMENT RELATED IN 
ANY MANNER TO USE OF INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED HEREIN OR 
OTHERWISE. The information contained within this document has been verified according to the general 
principles of electrical and mechanical engineering. 

eZ80 and eZ80Acclaim! are trademarks or registered trademarks of Zilog, Inc. All other product or service 
names are the property of their respective owners.

Warning:
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